Login    Register

Ethernet Nic not detected on Gigabyte Z87X-UD3H[Solved]

NIC, network controllers, compatibility questions, WOL, wake on lan
Forum rules
NAS4Free Official SiteSet-Up GuideFAQsForum Rules
  • Author
    Message

Ethernet Nic not detected on Gigabyte Z87X-UD3H[Solved]

Postby foxdoismil » 30 Aug 2013 06:47

I am not able to make my newly installed NAS4Free detect the Ethernet Nic on the Gigabyte Z87X-UD3H motherboard.

dmesg | grep -i ethernet returns the following:
pci0: <network, ethernet> at device 25.0 (no driver attached)

pciconf -lv | grep -B3 network
Class = simple comms
none1@pci0:0:25:0: class=0x20000 card=0xe0001458 chip=0x153b8086 rev=0x04
hdr=0x00
vendor = Íntel Corporation
class = network

I still do not know which Ethernet gigabit controller is it, but it appears that there is only one driver to download in the the
intel web site https://downloadcenter.intel.com/Detail ... ldID=17509

The file em-7.3.8.tar.gz contains only source codes that must be compiled.
I was not able to proceed because my NAS4Free does not have MAKE (c compiler).

questions:
1) Am I in the right way? Shall I have to compile the driver?
2) Is there any precompiled file?
3) tutorial to easy the pain of making this NIC work?
4) do you recomend any off board Ethernet NIC? Which one?

Thanks
    M/B : Gigabyte Z87X-UDH3 / CPU : Intel i7 3400 MHz / RAM : 32GB DDR3 1600 / Storage: 5x4TB Seagate NAS HDDs in RaidZ2 ~ 10.6 TB usable disk space
    O/S : NAS4Free 9.1.0.1.847 full / SAS/SATA Controller : LSI SAS 9211-8i SAS/SATA PCIe RAID Controller / Case : NZXT Model H2 - Classic Silent Middle Tower Chassis
PowerUser
foxdoismil
 
Posts: 27
Joined: 21 Dec 2012 18:46

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby b0ssman » 30 Aug 2013 06:56

its most likely the new intel i217 nic.

i should be supported in freebsd 9.2. http://www.freebsd.org/releases/9.2R/schedule.html
Nas4Free 9.1.0.1.573. ASUS - P8H61-M, 8gb G.Skill Sniper-ULV, i5 2500k, Intel 1Gbit Pcie Network, IBM M1015 with IT firmware. 4x 3tb WD Red, 4x 2TB Samsung F4, both GEOM AES 256 encrypted.
Forum Moderator
b0ssman

User avatar
 
Posts: 1605
Joined: 14 Feb 2013 07:34
Location: Munich, Germany

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby foxdoismil » 30 Aug 2013 23:24

Are there any tutorials on how to install a NIC driver?
    M/B : Gigabyte Z87X-UDH3 / CPU : Intel i7 3400 MHz / RAM : 32GB DDR3 1600 / Storage: 5x4TB Seagate NAS HDDs in RaidZ2 ~ 10.6 TB usable disk space
    O/S : NAS4Free 9.1.0.1.847 full / SAS/SATA Controller : LSI SAS 9211-8i SAS/SATA PCIe RAID Controller / Case : NZXT Model H2 - Classic Silent Middle Tower Chassis
PowerUser
foxdoismil
 
Posts: 27
Joined: 21 Dec 2012 18:46

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby raulfg3 » 31 Aug 2013 07:16

Use this for Realtek as tutorial, only need to use apropiate source viewtopic.php?f=58&t=222

http://blog.hani-ibrahim.de/en/netzwerk ... ieren.html


Remember , If You wait a little, in september a new BSD 9.2 is out, and a new N4F can be ready.
Site Admin
raulfg3

User avatar
 
Posts: 4019
Joined: 22 Jun 2012 20:13
Location: Madrid (ESPAÑA)

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby foxdoismil » 17 Sep 2013 22:08

I already had tried that, but in this case we only have the source code and not the binaries as in the tutorial.
I decided that buying an add-on Gigabit Ethernet board would be easier.
Both TP-Link TG-3468 (PCIe) or Dlink DGE528T (PCI) are good and cost effective Gigabit Ethernet NICs and will work fine with nas4free.

Either way. I was frustrated by having to wait a day or two and for not easily finding any driver solution.
    M/B : Gigabyte Z87X-UDH3 / CPU : Intel i7 3400 MHz / RAM : 32GB DDR3 1600 / Storage: 5x4TB Seagate NAS HDDs in RaidZ2 ~ 10.6 TB usable disk space
    O/S : NAS4Free 9.1.0.1.847 full / SAS/SATA Controller : LSI SAS 9211-8i SAS/SATA PCIe RAID Controller / Case : NZXT Model H2 - Classic Silent Middle Tower Chassis
PowerUser
foxdoismil
 
Posts: 27
Joined: 21 Dec 2012 18:46

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby raulfg3 » 18 Sep 2013 05:54

foxdoismil wrote:Either way. I was frustrated by having to wait a day or two and for not easily finding any driver solution.
sorry, but you must find/read if your mainboard/NIC is compatible with BSD prior to buy.

this is not linux, it's BSD and have less hardware compatibility/actuallizations of drivers: http://wiki.nas4free.org/doku.php?id=na ... s_hardware
Site Admin
raulfg3

User avatar
 
Posts: 4019
Joined: 22 Jun 2012 20:13
Location: Madrid (ESPAÑA)

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby apollo567 » 18 Sep 2013 17:33

get an other network card, e.g. one of Intel the older nics are fast and well supported in FreeBSD...
my NAS and its development until today: viewtopic.php?f=63&t=39
Site Admin
apollo567

User avatar
 
Posts: 384
Joined: 23 Jun 2012 04:37
Location: Ludwigshafen, Germany

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby foxdoismil » 19 Sep 2013 04:36

It appears that I did not express myself clearly.
The intention of my reply was to tell that i had already bought the new NICs and tested it successfully.
I just tried to help anyone who could face the same problem. That is why I mentioned the models.

I also took the opportunity to suggest that someone (with much better BSD knowledge than me) could make a tutorial on how to build a driver.
I tried, but my NAS4FREE does not have the "c" compiler installed. Than I started this thread.
    M/B : Gigabyte Z87X-UDH3 / CPU : Intel i7 3400 MHz / RAM : 32GB DDR3 1600 / Storage: 5x4TB Seagate NAS HDDs in RaidZ2 ~ 10.6 TB usable disk space
    O/S : NAS4Free 9.1.0.1.847 full / SAS/SATA Controller : LSI SAS 9211-8i SAS/SATA PCIe RAID Controller / Case : NZXT Model H2 - Classic Silent Middle Tower Chassis
PowerUser
foxdoismil
 
Posts: 27
Joined: 21 Dec 2012 18:46

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby DL84 » 09 Jan 2014 19:26

Well, here we are half a year later and im running into the same problem..have a mini itx board wich uses the intel i217, but nas4free has no support for it..what can i do? Could someone compile the driver from the intel source? I Of course you cant compile it in the nas4free shell because you cant use "make"..help would be greatly appreciated
PowerUser
DL84
 
Posts: 26
Joined: 07 Dec 2013 16:14

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby apollo567 » 09 Jan 2014 20:07

u have two Options:
wait for a N4F Version which is based on FreeBSD 9.2 or
buy an other Network adapter which is supported. A Intel Desktop CT Adapter is one a have good experiences with.
my NAS and its development until today: viewtopic.php?f=63&t=39
Site Admin
apollo567

User avatar
 
Posts: 384
Joined: 23 Jun 2012 04:37
Location: Ludwigshafen, Germany

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby DL84 » 09 Jan 2014 20:10

Not really in the mood to spend even more money right now, so i guess i can only wait..thank goodness my n4f system is still in its test stage
PowerUser
DL84
 
Posts: 26
Joined: 07 Dec 2013 16:14

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby apollo567 » 09 Jan 2014 20:26

zoon is currently more active again in programming, so maybe it won't last too long......
my NAS and its development until today: viewtopic.php?f=63&t=39
Site Admin
apollo567

User avatar
 
Posts: 384
Joined: 23 Jun 2012 04:37
Location: Ludwigshafen, Germany

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby raulfg3 » 09 Jan 2014 20:29

DL84 wrote:Not really in the mood to spend even more money right now, so i guess i can only wait..thank goodness my n4f system is still in its test stage



Please test this beta is based on BSD 9.2 and MUST Work. viewtopic.php?f=17&t=5608


PD: save your actual config.xml, do a new install and restore your previosly saved config , do it in a new bootdevice, if do not work, you only need to unplug and use old boot device to restore your boot.
Site Admin
raulfg3

User avatar
 
Posts: 4019
Joined: 22 Jun 2012 20:13
Location: Madrid (ESPAÑA)

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby DL84 » 09 Jan 2014 20:31

raulfg3 wrote:
DL84 wrote:Not really in the mood to spend even more money right now, so i guess i can only wait..thank goodness my n4f system is still in its test stage



Please test this beta is based on BSD 9.2 and MUST Work. viewtopic.php?f=17&t=5608


PD: save your actual config.xml, do a new install and restore your previosly saved config , do it in a new bootdevice, if do not work, you only need to unplug and use old boot device to restore your boot.

im already on it.
PowerUser
DL84
 
Posts: 26
Joined: 07 Dec 2013 16:14

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby apollo567 » 09 Jan 2014 20:38

Does it work then ?
my NAS and its development until today: viewtopic.php?f=63&t=39
Site Admin
apollo567

User avatar
 
Posts: 384
Joined: 23 Jun 2012 04:37
Location: Ludwigshafen, Germany

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby DL84 » 09 Jan 2014 20:40

Im on it i.e. im in the process of installing it on my usb stick ;) going to report later
PowerUser
DL84
 
Posts: 26
Joined: 07 Dec 2013 16:14

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby alexey123 » 09 Jan 2014 21:07

foxdoismil wrote:I
I still do not know which Ethernet gigabit controller is it, but it appears that there is only one driver to download in the the
intel web site https://downloadcenter.intel.com/Detail ... ldID=17509

The file em-7.3.8.tar.gz contains only source codes that must be compiled.
I was not able to proceed because my NAS4Free does not have MAKE (c compiler).



You have sources and Nas4Free have jail extension, called Thebrig - what problem compille driver?
I compilled it for x64 (9.1) during 1 minute ( I was have installed sources and ports
Download it free :P https://sites.google.com/site/aganimkar ... g/if_em.ko
Lab 9.1.0.1 - Sandstorm (revision 847) / x86-embedded on HP D530 / 2G RAM / CF IDE as system
Home9.2.0.1 - Sandstorm (revision 943) / x64-embedded on SAPPHIRE Pure Mini E350 / 4G RAM
Moderator
alexey123

User avatar
 
Posts: 1306
Joined: 19 Aug 2012 06:22
Location: Israel

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby DL84 » 10 Jan 2014 04:06

alexey123 wrote:
foxdoismil wrote:I
I still do not know which Ethernet gigabit controller is it, but it appears that there is only one driver to download in the the
intel web site https://downloadcenter.intel.com/Detail ... ldID=17509

The file em-7.3.8.tar.gz contains only source codes that must be compiled.
I was not able to proceed because my NAS4Free does not have MAKE (c compiler).



You have sources and Nas4Free have jail extension, called Thebrig - what problem compille driver?
I compilled it for x64 (9.1) during 1 minute ( I was have installed sources and ports
Download it free :P https://sites.google.com/site/aganimkar ... g/if_em.ko

Thank you very very much my man. I have to try this out, since the beta is giving me errors left and right.
PowerUser
DL84
 
Posts: 26
Joined: 07 Dec 2013 16:14

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby DL84 » 10 Jan 2014 15:15

well im running into another problem here..when i want to kldload the compiled driver it says "can't load /mnt/usb/if_em.ko: File exists"..i followed the instructions on the link above for the embedded version (since i use an usb stick (altho an older n4f version is shown in the guide))..can somebody give me some pointers? Does the driver have to be in a folder on the usb stick wich i just use for the transfer of this file?
PowerUser
DL84
 
Posts: 26
Joined: 07 Dec 2013 16:14

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby alexey123 » 10 Jan 2014 15:24

May be driver need something
print to forum result after
Code: Select all
dmesg
Lab 9.1.0.1 - Sandstorm (revision 847) / x86-embedded on HP D530 / 2G RAM / CF IDE as system
Home9.2.0.1 - Sandstorm (revision 943) / x64-embedded on SAPPHIRE Pure Mini E350 / 4G RAM
Moderator
alexey123

User avatar
 
Posts: 1306
Joined: 19 Aug 2012 06:22
Location: Israel

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby DL84 » 10 Jan 2014 15:35

thats a too long list to type out, since i can't access the n4f box over the webgui (card is not detected)..what specifically do you need to know from the output?
PowerUser
DL84
 
Posts: 26
Joined: 07 Dec 2013 16:14

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby alexey123 » 10 Jan 2014 15:42

Code: Select all
tail -n 3 /var/run/dmesg.boot

Will wrote last 3 lines dmesg
Lab 9.1.0.1 - Sandstorm (revision 847) / x86-embedded on HP D530 / 2G RAM / CF IDE as system
Home9.2.0.1 - Sandstorm (revision 943) / x64-embedded on SAPPHIRE Pure Mini E350 / 4G RAM
Moderator
alexey123

User avatar
 
Posts: 1306
Joined: 19 Aug 2012 06:22
Location: Israel

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby DL84 » 10 Jan 2014 15:46

okay it says:

GEOM: ada2: corrupt or invalid GPT detected
GEOM: ada2: GPT rejected -- may not be recoverable
Trying to mount root from ufs:/dev/md0 []...


and thats that
PowerUser
DL84
 
Posts: 26
Joined: 07 Dec 2013 16:14

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby alexey123 » 10 Jan 2014 15:51

Power of your server and remove broken drive.
Lab 9.1.0.1 - Sandstorm (revision 847) / x86-embedded on HP D530 / 2G RAM / CF IDE as system
Home9.2.0.1 - Sandstorm (revision 943) / x64-embedded on SAPPHIRE Pure Mini E350 / 4G RAM
Moderator
alexey123

User avatar
 
Posts: 1306
Joined: 19 Aug 2012 06:22
Location: Israel

Re: Ethernet Nic not detected on Gigabyte Z87X-UD3H

Postby DL84 » 10 Jan 2014 15:52

its not broken, its because i changed the mobo/cpu..but yeah already took them out, still the same problem of "file exists" when trying to kldload
PowerUser
DL84
 
Posts: 26
Joined: 07 Dec 2013 16:14

Next

Return to LAN , Network controllers

Who is online

Users browsing this forum: No registered users and 1 guest